Website pages Developer dashboard outage

Incident Report for Infura

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 20:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 14:51 UTC

Identified

We are aware of an outage affecting some of our Website pages and Developer Dashboard endpoints. At the moment, the outage is limited to the listed components, which are temporarily unavailable. The issue has been identified as related to a Cloudflare interruption, and we are currently investigating to pinpoint a root cause and implement a resolution.
Posted Nov 18, 2025 - 12:37 UTC
This incident affected: Infura Website (Website pages, Developer dashboard).